+ Reply to Thread
Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: Using Hamster on Linux

  1. #1
    abhishek@bioenable
    Guest

    Using Hamster on Linux

    To use Hamster on Linux, you need these drivers:

    * VenusDrv-1.0.1-7.2 - NITGEN USB Fingkey Hamster(HFDU01/HFDU04)
    * ngstardrv-1.0.0-3 - NITGEN USB Fingkey Hamster II(HFDU11/HFDU14)

    The folder attached here,Hamster Drv.zip, contains the required drivers.


    Get the drivers and start installing as per the following instructions:
    Open terminal and un-tar the driver file as given below.
    Code:
    tar -zxvf VenusDrv-1.0.1-7.2.tar.gz
    or
    Code:
    tar -zxvf ngstardrv-1.0.0-3.tar.gz
    Now go to the location where you placed the driver files. An example is given below.
    Code:
    cd /home/VenusDrv-1.0.1-7.2/gcc4.0
    Install as given below:

    Code:
    ./CreateModule
    ./CreateModule should create VenusDrv.ko file required for further process.


    Code:
    ./install.sh
    Wait till you get installation success message.
    (Similarly you can install ngstardrv.)

    For VenusDrv:-

    VenusLib.so -----> /lib
    VenusDrv.ko -----> /lib/modules/$kernelversion/kernel/drivers/usb/misc/
    VenusDrv.h ------> /usr/include/linux/
    VenusDrv.conf ---> /etc/
    Device node -----> /dev/nitgen0 to nitgen7


    For ngstardrv:-


    ngstarlib.so -----> /lib
    ngstardrv.ko -----> /lib/modules/$kernelversion/kernel/drivers/usb/misc/
    ngstardrv.h ------> /usr/include/linux/
    ngstardrv.conf ---> /etc/
    Device node -----> /dev/ngstar0 to ngstar7
    Conect the device to Linux PC.

    Now give the following command to install the module:

    Code:
    #For VenusDrv - 
    insmod /lib/modules/$kernelversion/kernel/drivers/usb/misc/VenusDrv.ko
    
    #For ngstardrv - 
    insmod /lib/modules/$kernelversion/kernel/drivers/usb/misc/ngstardrv.ko
    Where $kernelversion is your kernal version obtained from command:
    Code:
    uname -r
    It is recommanded to add the above two lines to start-up .i.e add these lines to /etc/rc.local file.

    In most of the cases, some systems used to remove the driver node in /dev directory (see above) which is
    loading the device driver temporarily whenever it was rebooted. So, in this case, you have to install again the device driver after rebooting and then add the following sentence on the "/etc/rc.local"

    Code:
    KER_VER=`uname -r`
    DRIVER_PATH="/lib/modules/$KER_VER/kernel/drivers/usb/misc/"
    device="nitgen"               #for VenusDrv
    device1="ngstar"             #for NgstarDrv
    major=180
    
    #remove  stale node
    rm -f /dev/${device}[0-7]
    rm -f /dev/${device1}[0-7]
    
    #create 8 nodes for the  device for VenusDrv
    mknod /dev/${device}0 c $major 230
    mknod /dev/${device}1 c  $major 231
    mknod /dev/${device}2 c $major 232
    mknod  /dev/${device}3 c $major 233
    mknod /dev/${device}4 c $major 234
    mknod  /dev/${device}5 c $major 235
    mknod /dev/${device}6 c $major 236
    mknod  /dev/${device}7 c $major 237
    
    #create 8 nodes for the  device for NgstarDrv
    mknod /dev/${device1}0 c $major 238
    mknod /dev/${device1}1 c  $major 239
    mknod /dev/${device1}2 c $major 240
    mknod  /dev/${device1}3 c $major 241
    mknod /dev/${device1}4 c $major 242
    mknod  /dev/${device1}5 c $major 243
    mknod /dev/${device1}6 c $major 244
    mknod  /dev/${device1}7 c $major 245
    
    /sbin/insmod ${DRIVER_PATH}VenusDrv.ko   # to install module as described above
    /sbin/insmod ${DRIVER_PATH}ngstardrv.ko
    To test the Hamster:-

    Un-tar the file eNBSP-1.8.1-1.tar.gz.
    Go to the folder eNBSP-1.8.1-1 and install it by executing install.sh file as given below:
    Code:
    ./install.sh
    Now give the serial number you have after executing
    Code:
    ./NBioBSP_Signer
    This completes the installation process.

    Now go to /eNBSP-1.8.1-1/eNBSP/bin and execute the NbioBSPDemo file
    Code:
    ./NBioBSPDemo
    A GUI will open. You can test the application now.

    Select the device FDU01/FDU14 as appear in the device list.

    Click image for larger version

Name:	Select_device.JPG
Views:	61
Size:	97.5 KB
ID:	193

    Enter the user name in Enroll section and click "Enroll".

    Click image for larger version

Name:	Enroll.JPG
Views:	27
Size:	97.5 KB
ID:	194

    Now the LEDs on hamster will flash indicating the user to enroll his finger. The confirmation of finger enrollment will be given as

    Click image for larger version

Name:	Enroll1.JPG
Views:	26
Size:	98.7 KB
ID:	195

    To very a registered finger print, click "Verify" in Verify section.
    Place the registered on hamster. If the finger is verified, following message will be displayed.

    Click image for larger version

Name:	verified.JPG
Views:	24
Size:	102.9 KB
ID:	196
    Last edited by abhishek@bioenable; 05-11-2010 at 06:54 PM.

  2. #2
    hello,

    do those drivers work on any linux-based system? i'm using fedora, but i'll need the reader on ubuntu, im doing some test in both OS, but i get some problems while installing the drivers, do i need certain version of gcc, or any specific library on my system?

    i'll post the error message later, i'm not in my computer now.

    thanks a lot xD

  3. #3
    Go through the attached pdf for details on the same

  4. #4
    hi again, and thanks,

    yes i'm following that pdf, and i'm following the instructions,


    ------------------ this commands -----------
    ]#tar -zxvf ngstardrv-1.0.0-3.tar.gz
    ]#cd ngstardrv-1.0.0-3
    ]#cd [gcc3.3 or gcc4.0]
    ]#./CreateModule
    ]#./install.sh
    ----------------------------------------------


    but at the 4th line i've got and error :
    while creating module
    --------------------------------------------------------------------------------------------------------------
    [root@LOPEZLNX gcc4.0]# ./CreateModule
    make -C /lib/modules/2.6.34.7-61.fc13.x86_64/build SUBDIRS=/media/DATOS2/ADSUM/lector de huella /driver_lnx/Hamster DrvCopia/ngstardrv-1.0.0-3/gcc4.0/tempDirectory modules
    make[1]: Entering directory `/usr/src/kernels/2.6.34.7-61.fc13.x86_64'
    make[1]: *** No rule to make target `de'. Stop.
    make[1]: Leaving directory `/usr/src/kernels/2.6.34.7-61.fc13.x86_64'
    make: *** [default] Error 2
    mv: cannot stat `ngstardrv.ko': No such file or directory
    Create Module success.
    [root@LOPEZLNX gcc4.0]#
    --------------------------------------------------------------------------------------------------------------


    then if i try to run the install command i've got this message:
    --------------------------------------------------------------------------------------------------------------
    [root@LOPEZLNX gcc4.0]# ./install.sh

    ngstardrv.ko or ngstardrv.h file not found in current dir .....
    [root@LOPEZLNX gcc4.0]#
    --------------------------------------------------------------------------------------------------------------


    do you have any idea of what is happening or if i need to do anything else?

    thanks xD

  5. #5
    OMG!!! lol

    i'm trying again, now i've looked a little bit about the error, it appears it was because of the blanks spaces in the path

    first i was here:
    /media/DATOS2/ADSUM/lector de huella/driver_lnx/Hamster DrvCopia/ngstardrv-1.0.0-3/gcc4.0/

    now i've moved it to here and tried again:
    /media/DATOS2/HamsterDrvCopia/ngstardrv-1.0.0-3/gcc4.0

    it appears everything is ok, unfortunatelly i don't have the reader now, i'll tell you what happens then.

    thanks xD

  6. #6
    hii here i'm again xD

    now everything goes (almost) ok

    i inserted the module (with little problems but ok at the end), now i want to test,

    i ran the ./install.sh command

    then this one ./NBioBSP_Signer that asks for a serial number, erere...i'm a kind of confused, is this test programme sold? do i need to buy something? or i can get that serial number from somewhere else? in my fingerPring-reader device,maybe?

    i dunno understand very well the reader, i'm developing a java-based system, with a linux OS, and the finger print reader.

    the components are the hardware device, a JDK (what for??), the system drivers and that's all. am i wrong? or totally lost?

    thanks for the help =D

  7. #7
    Yes it needs to be purchased. you can write email on sales@bioenabletech.com if you wants to purchase the same. We can provide Enbsp SDK on linux through which you can develop your own application.

  8. #8
    ok thanks a lot xD

    i'll check this out then. hehe and i'll post any problem i get, if any.

    =D

  9. #9
    Hi

    to execute the command,

    insmod /lib/modules/$kernelversion/kernel/drivers/usb/misc/VenusDrv.k
    got the error:
    root@ubuntu:/sbin# insmod /lib/modules/2.6.32-24-generic/kernel/drivers/usb/misc/VenusDrv.ko
    insmod: error inserting '/lib/modules/2.6.32-24-generic/kernel/drivers/usb/misc/VenusDrv.ko': -1 File exists


    thanks all.






  10. #10
    hi pradox

    well , i think that happens when you have already inserted the module, so the file 'already exist'

    when you execute that command more than one time.

    but check the help
    'insmod -?' or 'insmod --?' of 'insmod -help' or 'insmod --help'

    there must be a 'force' option like 'insmod -f'

    that replace the current file. =D

    try that and tell us what happen

+ Reply to Thread
Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts